Задать вопрос
3 ноября, 05:38

Напишите программу, которая шифрует тексты следующим образом: Исходная строка разбивается на части по 3 символа и эти три символа перемещаются по кругу вправо на одну позицию. Если последняя группа символов состоит из 1 или 2 символов, то они остаются неизменными

turbo pascal

+1
Ответы (1)
  1. 3 ноября, 08:04
    0
    Var s:string; c:char; i:integer;

    begin

    writeln ('Введите строку:') ;

    readln (s) ;

    for i:=0 to length (s) div 3-1 do

    begin

    c:=s[3*i+3];

    s[3*i+3]:=s[3*i+2];

    s[3*i+2]:=s[3*i+1];

    s[3*i+1]:=c;

    end;

    writeln (s) ;

    end.

    Пример:

    Primer, begin, end. iPrrmeb, ieg n, den.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая шифрует тексты следующим образом: Исходная строка разбивается на части по 3 символа и эти три символа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Роботу дано число 123. он меняет цифры в соответствии со следующими командами "влево" - переместится в числе на одну позицию влево, "вправо" - переместится в числе на одну позицию вправо, "вверх" - заменить текущую цифру на следующую по возрастанию,
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)