Задать вопрос
15 декабря, 15:15

1. Разработать и написать алгоритм определения

S = b (c + d) / (k - 1).

2. Составить алгоритм вычисления х! = 1*2*3 * ... * х.

+5
Ответы (1)
  1. 15 декабря, 17:02
    0
    Program p17;

    var b, c, d, k, S: real;

    begin

    writeln ('Введите b: ') ;

    readln (b) ;

    writeln ('Введите c: ') ;

    readln (c) ;

    writeln ('Введите d: ') ;

    readln (d) ;

    writeln ('Введите k: ') ;

    readln (k) ; S:=b * (c + d) / (k - 1) ;

    writeln (S) ;

    end.

    Program p17;

    var x, S:integer;

    begin

    writeln ('Введите x: ') ;

    S:=1;

    readln (x) ;

    while x>0 do

    begin

    S:=S*x;

    x:=x-1;

    end;

    writeln (S) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Разработать и написать алгоритм определения S = b (c + d) / (k - 1). 2. Составить алгоритм вычисления х! = 1*2*3 * ... * х. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
Какой алгоритм называется линейным? А. Алгоритм, в котором имеется ввод данных, вычисления и вывод результатов. Б. Алгоритм, в котором для получения результатов последовательно выполняются все операторы по одному разу В.
Ответы (1)
1. Разработать программу алгоритма для подсчета количества отрицательных чисел среди целых чисел a, b, c. Протестировать алгоритм для всех возможных случаев (когда количество отрицательных чисел равно 0, 1, 2 и 3). 2.
Ответы (1)
Разработать алгоритм и составить программу вычисления значений по формулам: z=sin^2 (x+g) + cosx/x+y^2ln|x-y|, где y=x+корень|1-x^2|
Ответы (1)
Разработать алгоритм и составить программу вычисления значений по формулам: p = (a+) ^2+a cos (a+b) + акореньb/a+b, где a=x+y, b=x^2+y^2
Ответы (1)