Задать вопрос
23 апреля, 04:11

Даны 4 целых числа. Найти сумму и количество чётных чисел то есть написать программу

+3
Ответы (1)
  1. 23 апреля, 07:41
    0
    Const

    handsfree = false;

    nmax = 4;

    random_min = - 50;

    random_max = 50;

    var

    a: array[1 ... nmax] of integer;

    i, n, j: integer;

    sum, product, harmonic: real;

    k: integer;

    begin

    {ввод массива}

    n : = nmax;

    writeln ('Данные массива:') ;

    for i : = 1 to n do

    begin

    if handsfree then begin

    a[i] : = random (random_max - random_min) + random_min;

    write (a[i], ' ') ;

    end

    else

    readln (a[i]) ;

    end;

    writeln () ;

    {подсчет элементов}

    k : = 0;

    for i : = 1 to n do

    if a[i] mod 2 = 0 then

    k : = k + 1;

    writeln ('quantity = ', k) ;

    {подсчет суммы и произведения и агригатов}

    sum : = 0;

    for i : = 1 to n do

    sum : = sum + a[i];

    writeln ('sum = ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны 4 целых числа. Найти сумму и количество чётных чисел то есть написать программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
Напишите программу, которая для последовательности целых чисел определяет количество четных чисел. Программа получает на вход количество чисел в последоввтельности, а затем сами числа. Количество чисел не привышает 1000.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Задача 4. Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)