Задать вопрос
19 сентября, 01:57

Запишите программу в синтаксисе паскаль ABC которая заполняет массив случайными числами на отрезке от - 2 до 2 и считает сумму положительных элементов массива. Когда будете писать программу, не забывайте что в 9 м классе простые алгоритмы и еще более простые операторы.

+2
Ответы (1)
  1. 19 сентября, 04:00
    0
    Const

    kk=100; { максимальный размер массива }

    var

    a:array[1 ... kk] of integer;

    i, k, s:integer;

    begin

    Write ('Введите количество элементов массива: ') ;

    Read (k) ;

    Randomize;

    s:=0;

    for i:=1 to k do begin

    a[i]:=Random (5) - 2;

    Write (a[i],' ') ;

    if a[i]>0 then s:=s+a[i]

    end;

    Writeln;

    Writeln ('Сумма положительных элементов массива равна ', s)

    end.

    Пример

    Введите количество элементов массива: 20

    2 2 1 - 2 - 1 - 1 1 0 1 2 1 0 2 1 2 - 2 - 1 - 1 - 1 - 2

    Сумма положительных элементов массива равна 15
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Запишите программу в синтаксисе паскаль ABC которая заполняет массив случайными числами на отрезке от - 2 до 2 и считает сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Запишите программу которая заполняет массив случайными числами на отрезке от - 2 до 2 и считает сумму положительных элементов массива
Ответы (1)