Задать вопрос
12 февраля, 00:07

Определить количество положительных элементов в каждой строке двумерного массива P (4,5)

+1
Ответы (2)
  1. 12 февраля, 03:32
    0
    Var

    a: array[1 ... 50,1 ... 50] of integer;

    i, j, n, m: integer;

    Begin

    Write ('Andrei Balashov') ;

    Readln (Andrei Balashov) ;

    Write (‘how many lines?’) ;

    Readln (m) ;

    Write (‘ how many columns?’) ;

    Readln (n) ;

    For i:=1 to m do

    begin

    For j:=1 to n do

    begin

    a[i, j]:=int (rnd*46) - 20;

    write (a[i, j],’ ‘) ;

    end;

    writeln;

    end;

    End.

    Введите на в окне которое вам откроется данные массива и программа самостоятельно его посчитает.

    Вопросы я написал на английском внутри программы.
  2. 12 февраля, 03:36
    0
    Var

    p:array [1 ... 4,1 ... 5] of integer;

    i, j, k:integer;

    begin

    for i: = 1 to 4 do

    begin

    for j:=1 to 5 do

    begin

    p[i, j]:=Random (-100,100) ;

    write (p[i, j]:5) ;

    end;

    writeln;

    end;

    for i: = 1 to 4 do

    begin

    k:=0;

    for j:=1 to 5 do

    if p[i, j]>0 then k:=k+1;

    writeln ('Количество положительных элементов в строке ', i,' равно: ', k) ;

    end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить количество положительных элементов в каждой строке двумерного массива P (4,5) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. В третьей строке записано число X.
Ответы (1)