Задать вопрос
17 мая, 11:08

Определить количество чисел в промежутке от a до b и их сумму, если числа целые

+4
Ответы (1)
  1. 17 мая, 11:15
    0
    Var

    a, b, i, sum, k:integer;

    begin

    write ('Введите a: ') ;

    readln (a) ;

    write ('Введите b: ') ;

    readln (b) ;

    k:=0;

    sum:=0;

    for i:=a to b do begin

    k:=k+1;

    sum:=i+sum;

    end;

    writeln ('Сумма чисел, находящихся в диапазоне от ', a,' до ', b,' = ', sum) ;

    Write ('Их кол-во = ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить количество чисел в промежутке от a до b и их сумму, если числа целые ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Числа в языке Pascal различаются: А) как натуральные и целые; Б) как целые и вещественные; В) как натуральные и вещественные; Г) как целые и иррациональные; Д) как целые и рациональные.
Ответы (1)
1. Определите сколько раз будет выполняться тело цикла, при вычислении:y=5x+12a на промежутке [-6; 6 ] с шагом 2. 2. Определите сколько раз будет выполняться тело цикла, при вычислении:y=7/12a на промежутке [-2; 1 ] с шагом 0,5. 3.
Ответы (1)
Даны свойства поля в Ворде к ним надо подобрать правильные варианты1) целые числа 0 до 225 2) целые числа от - 32768 до 32767 3) целые числа от - 2147483648 до 2147483647 4) числа от - 1,797*10308 до 1,797*10308 Byte - Long Integer - Double -
Ответы (1)
Даны целые числа a и b. Найти их удвоенную сумму. Дано: a и b-целые числа (integer) Найти: u-удвоенную сумму (сумма целых чисел s - целое число, удвоенное целое - целое число integer)
Ответы (1)