Задать вопрос
2 февраля, 18:31

Написать программу, в которой в массиве из 15 случайных целых чисел, на отрезке от - 5 до 5, числа равные 0 заменяются на 1

+3
Ответы (1)
  1. 2 февраля, 21:11
    0
    Если это на Паскаль, то:

    program special_for_raushan; const n=15; var i: integer; a: array [1 ... n] of integer; beginrandomize; for i:=1 to n do begin a[i]:=random (11) - 5; write (a[i],' ') ; end; writeln; for i:=1 to n do beginif a[i]=0 then a[i]:=1; write (a[i],' ') ; end; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, в которой в массиве из 15 случайных целых чисел, на отрезке от - 5 до 5, числа равные 0 заменяются на 1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1. В массиве А (11) случайных целых чисел (диапазон чисел [-10 ... 25]) определить: сумму элементов, которые кратны 5. 2. В массиве B (6) случайных целых чисел (диапазон чисел [-4 ... 53]) определить: количество элементов, которые меньше 7.
Ответы (1)
Напишите программу в Python 3.3 Напишите программу, которая вводит два целых числа, a и b (a < b), и выводит через пробел 5 случайных целых чисел на отрезке [ a, b ]. Входные данные Входная строка содержит два целых числа a и b, разделённых пробелом.
Ответы (1)
Ответьте в кумире или Паскале 1. Найти среднее арифметическое значений всех элементов массива, состоящего их случайных положительных чисел. 2. В массиве из 15-ти целых случайных чисел из диапазона [-30; 70] найти минимальный положительный элемент. 3.
Ответы (1)
В питоне Напишите программу, которая вводит два целых числа, a и b (a < b), и выводит через пробел 5 случайных целых чисел на отрезке [ a, b ]. Входные данные Входная строка содержит два целых числа a и b, разделённых пробелом.
Ответы (1)