Задать вопрос
30 апреля, 00:38

Написать программу на С + + 3. Известен факториал числа (вводится с клавиатуры). Найти это число.

+1
Ответы (1)
  1. 30 апреля, 02:17
    0
    1.

    #include

    using namespace std;

    int main ()

    {

    int f, n, p;

    cin >> f;

    n = 0;

    p = 1;

    while (p
    n++;

    p*=n;

    }

    if (p==f) cout << n;

    else cout << "Ошибка ввода";

    system ("pause") ;

    }

    2.

    #include

    using namespace std;

    int main ()

    {

    int f, n, p;

    cin >> f;

    p = 1;

    for (n=1; p
    if (p==f) cout << n-1;

    else cout << "Ошибка ввода";

    system ("pause") ;

    }

    Пример:

    120

    5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на С + + 3. Известен факториал числа (вводится с клавиатуры). Найти это число. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
С помощью repeat S = (x / (факториал) 1) + (х^2 / (факториал) 2) + (х^3 / (факториал) 3) + ... + (х^n / (факториал) n) + 0,0001
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
С клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестс клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестии
Ответы (1)