Задать вопрос
1 декабря, 04:54

Помогите с задачей в pascal. введите символ с клавиатуры Найдите сумму произведение и среднее арифметическое и среднее геометрическое цифр его кода

+2
Ответы (2)
  1. 1 декабря, 05:28
    0
    Var c:char; a, s, p, k:integer;

    begin

    readln (c) ;

    a:=ord (c) ;

    writeln ('code = ', a) ;

    s:=0; k:=0; p:=1;

    while a>0 do

    begin

    s:=s+a mod 10;

    p:=p * (a mod 10) ;

    k:=k+1;

    a:=a div 10;

    end;

    writeln ('s = ', s,' p = ', p,' sr = ', s/k:5:2) ;

    end.

    Пример:

    &

    code = 38

    s = 11 p = 24 sr = 5.50
  2. 1 декабря, 07:32
    0
    Var

    a, b, c: integer;

    begin

    writeln ('Введите 3 числа: ') ;

    readln (a, b, c) ;

    writeln (a,' + ', b,' + ', c,' = ', a+b+c) ;

    writeln (a,' * ', b,' * ', c,' = ', a*b*c) ;

    writeln ('Среднее арифметическое чисел = ', (a+b+c) / 3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с задачей в pascal. введите символ с клавиатуры Найдите сумму произведение и среднее арифметическое и среднее геометрическое цифр ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Злой хакер хочет испортить программное обеспечение на 40 компьютерах компании. На каждом компьютере 37 программ, каждая из которых состоит из 9000 строк кода.
Ответы (2)
Написать в тетради программу на Pascal: Спросить у пользователя три числа. Вывести сумму чисел, среднее значение. Пример: Введите а: 5 Введите b:4 Введите c:3 Сумма: 12 Среднее: 6
Ответы (1)
Укажите алгоритмы устранения следующих ошибок: 1) Установить курсор на место вставки. 2) Нажать клавишу с нужным символом. Что это Лишний символ, пропущенный символ, неверный символ? 1) Установить курсор за ошибочным символом.
Ответы (1)