Задать вопрос
11 января, 06:42

Помогите решить задачу на Паскале

Заданное натуральное число N Андрей записал ручкой на листе бумаги, после чего ножницами порезал лист по линиям, которые были оставлены ручкой. В результате лист распался на несколько частей. Напишите алгоритм, который определяет сколько частей получилось.

+1
Ответы (1)
  1. 11 января, 09:28
    0
    Var n, s: integer;

    begin

    readln (n) ;

    s : = 1;

    repeat

    case n mod 10 of

    0, 6, 9: inc (s) ;

    8: inc (s, 2)

    end;

    n : = n div 10

    until n = 0;

    writeln (s)

    end.

    За правильность не отвечаю))
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу на Паскале Заданное натуральное число N Андрей записал ручкой на листе бумаги, после чего ножницами порезал лист по ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Наташа, Валя, Маша, Галя и Лена вырезали из бумаги разные фигуры. Кто-то вырезал круг из бумаги в клетку, кто-то круг из бумаги в линейку, кто-то квадрат из бумаги в клетку, кто-то квадрат из бумаги в линейку, кто-то флажок из белой бумаги.
Ответы (2)
1). Натуральное число, на которое заданное натуральное число делится без остатка! 2). Натуральное число, имеющее только два делителя: единицу и само число 3). Два числа, произведение которых равно 1 помогите плииз) оч надо)
Ответы (1)
Ниже на пяти языках программирования записан алгоритм. Получив на вход натуральное число x, этот алгоритм печатает число R. Укажите такое число x, при вводе которого алгоритм печатает двузначное число, сумма цифр которого равна 13.
Ответы (1)
Дано целое число X и натуральное N. Составьте алгоритм вычисления X^N. Проверьте алгоритм трассировкой. Напишите программу на Паскале.
Ответы (1)
Напишите программы на Паскале, используя цикл "Пока". 1) Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. 2) Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^N.
Ответы (1)