Задать вопрос
14 января, 00:49

Даны действительные числа x1, y1, x2, y2, x3, y3. Выясните является треугольник с такими вершинами равносторонний.

Помогите составить программу! Pascal

+1
Ответы (1)
  1. 14 января, 02:50
    0
    Program n1;

    var kord: array[1 ... 6] of real;

    st: array [1 ... 3] of real;

    i: integer;

    begin

    i:=1;

    while i<=6 do

    begin

    write ('введите координаты точки через пробел: ') ;

    readln (kord[i], kord[i+1]) ;

    i:=i+2;

    end;

    st[1]:=sqrt (sqr (kord[3]-kord[1]) + sqr (kord[4]-kord[2])) ;

    st[2]:=sqrt (sqr (kord[5]-kord[1]) + sqr (kord[6]-kord[2])) ;

    st[3]:=sqrt (sqr (kord[5]-kord[3]) + sqr (kord[6]-kord[4])) ;

    if (st[1]=st[2]) and (st[2]=st[3]) then write ('треугольник равносторонний') else write ('треугольник не равносторонний') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны действительные числа x1, y1, x2, y2, x3, y3. Выясните является треугольник с такими вершинами равносторонний. Помогите составить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны действительные числа x1, y1, x2, y2, x3, y3. Выясните является треугольник с такими вершинами равносторонний. Помогите! Pascal
Ответы (1)
Даны 3 стороны треугольника, составить программу в которой нужно определить равносторонний ли треугольник, если равносторонний, то вывести на экран сообщение треугольник - равносторонний
Ответы (1)
Даны действительные числа X1, Y1, X1,72, X3, Y3. Выясните является треугольник с такими вершинами равнобедренным.
Ответы (1)
напишите программу: даны действительные числа a b c. если нельзя построить треугольник с такими сторонами то напечатать 0, иначе 3,2 или 1 в зависимости от того, равносторонний этот треугольник, равнобедренный или какой-либо другой.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)