Задать вопрос
28 ноября, 19:18

Пользователь вводит на натуральное число, программа должна рассчитать произведение цифр числа. 9 класс. Язык Паскаль. Прошу наберите программу, как это делается!))

+3
Ответы (2)
  1. 28 ноября, 19:34
    0
    Program pr_ch;

    Uses Crt;

    var

    n, pr: integer;

    begin

    write ('Введите число: ') ;

    readln (n) ;

    pr : = 1;

    while n > 0 do begin

    pr : = pr * (n mod 10) ;

    n : = n div 10

    end;

    writeln ('Произведение чисел: ', pr) ;

    readln;

    end.
  2. 28 ноября, 20:45
    0
    Var a, p:integer;

    begin

    write ('a (>0) = ') ;

    readln (a) ;

    p:=1;

    while a>0 do

    begin

    p:=p * (a mod 10) ;

    a:=a div 10;

    end;

    writeln ('p = ', p) ;

    end.

    Пример:

    a (>0) = 1385

    p = 120
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Пользователь вводит на натуральное число, программа должна рассчитать произведение цифр числа. 9 класс. Язык Паскаль. Прошу наберите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программа должна выдавать ошибку если пользователь вводит ноль во втором числе, т. к на 0 делить нельзя и программа отправляет пользователя на повторный ввод, если пользователь умудряется допустить ошибку 3 раза подряд, то программа закрывается.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
3. Напишите и выполните программу на компьютере a. Программа вводит одно число, и вычисляет его квадрат, вычитая из него удвоенное значение введенного числа. b. Программа вводит два числа, выводит сумму квадратов этих чисел минус их произведение. c.
Ответы (1)
Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36).
Ответы (1)
1) Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком.
Ответы (1)