Задать вопрос
3 июня, 15:02

Дано двузначное число. Определить, равен ли квадрат этого числа сумме квадратов его цифр - Pascal ABC

+4
Ответы (1)
  1. 3 июня, 16:02
    0
    1.

    var a:longint;

    begin

    read (A) ;

    if (a mod 10) = (a div 10) then writeln ('цифры одинаковы') ;

    if (a mod 10) > (a div 10) then writeln ('вторая цифра больше') ;

    if (a div 10) > (a mod 10) then writeln ('первая цифра больше') ;

    end.

    2.

    var a, b, c:longint;

    begin

    read (A) ;

    b:=a mod 10;

    c:=a div 10;

    b:=b*b*b;

    c:=c*c*c;

    d:=4 * (b+c) ;

    if sqr (A) = d then writeln (' квадрат этого числа равен учетверённой сумме кубов его цифр') else writeln (' квадрат этого числа не равен учетверённой сумме кубов его цифр') ;

    end.

    3.

    var a, b, c, d:longint;

    begin

    read (A) ;

    b:=a mod 10;

    c:=a div 10;

    d:=c+b;

    if d mod 3=0 then writeln ('сумма цифр данного числа кратна 3') else writeln ('сумма цифр этого числа не кратна 3') ;

    if d mod 4=0 then writeln ('сумма цифр данного числа кратна 4') else writeln ('сумма цифр этого числа не кратна 4') ;

    end.

    4.

    var a, b, c, d, e:longint;

    begin

    read (A) ;

    b:=a mod 10;

    c: = (a mod 100) div 10;

    d:=a div 100;

    b:=b*b*b;

    c:=c*c*c;

    d:=d*d*d;

    e:=b+c+d;

    if sqr (A) = e then writeln ('квадрат этого числа равен сумме кубов его цифр.') else writeln ('квадрат этого числа не равен сумме кубов его цифр.') ;

    end.

    5.

    var a, b, c, d:longint;

    begin

    read (b, a) ;

    c:=b mod 10;

    d:=b div 10;

    if (c=3) or (d=3) then writeln ('в запись этого числа входит цифра 3') else writeln ('в запись этого числа не входит цифра 3') ;

    if (c=a) or (d=a) then writeln ('в запись этого числа входит цифра ', a') else writeln ('в запись этого числа не входит цифра ', a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано двузначное число. Определить, равен ли квадрат этого числа сумме квадратов его цифр - Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Программа в Pascal ABC: Дано натуральное число. Определить: а) количество цифр в нем; б) сумму его цифр; б) сумму квадратов его цифр.
Ответы (1)