Задать вопрос
2 ноября, 07:33

Найти сумму цифр 3-х значного числа, если оно больше 500, если меньше то произведение.

+5
Ответы (1)
  1. 2 ноября, 08:48
    0
    Вот держите:

    var a:integer;

    begin

    readln (a) ;

    if a<500 then writeln ((a mod 10) + (a div 10 mod 10) + (a div 100))

    else if a>500 then writeln ((a mod 10) * (a div 10 mod 10) * (a div 100)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму цифр 3-х значного числа, если оно больше 500, если меньше то произведение. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
Для числа подсчитывается сумма его цифр. Если результат превышает 9, то для результата снова подсчитывается сумма цифр и так далее, пока результат не станет меньше 10. Выполните расчеты для введенного с клавиатуры не более чем 50-значного числа.
Нет ответа
Помогите! написать программу которая для 3 х значного числа если оно четное то возводит в квадрат, а если не четное то находит сумму цифр
Ответы (1)