Задать вопрос
14 июня, 03:06

Функция. напишите программу для нахождения наибольшего числа из 5 чисел. Для сравнения двух чисел создать соответствующую функцию

+2
Ответы (1)
  1. 14 июня, 05:42
    0
    Function Max (a, b:real) : real;

    begin

    if a>b then Max:=a

    else Max:=b

    end;

    var

    a, b, c, d, e, m:real;

    i:integer;

    begin

    Writeln ('Введите 5 чисел: ') ;

    Read (a, b, c, d, e) ;

    m:=Max (a, b) ;

    m:=Max (m, c) ;

    m:=Max (m, d) ;

    m:=Max (m, e) ;

    Writeln ('Максимум: ', m)

    end.

    Пример

    Введите 5 чисел:

    2.3 4 - 5.16 0 0.087

    Максимум: 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Функция. напишите программу для нахождения наибольшего числа из 5 чисел. Для сравнения двух чисел создать соответствующую функцию ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип математической функции: 1-квадрат, 2-куб, 3 - корень квадратный, 4 - обратная функция, а также аргумент функции x и вычисляет для x соответствующую математическую функцию.
Ответы (1)
На диске D необходимо выполнить следующую последовательность действий:, Создать каталог МИН, Открыть каталог МИН, Создать каталог 1, Открыть каталог 1, Создать каталог 11, Подняться на 1 уровень вверх, Создать каталог 2, Подняться на 1 уровень
Ответы (1)
1. Составить программу максимума из двух чисел. 2. Составить программу вычисления наибольшего из четырех чисел с использованием процедуры определения наибольшего из двух чисел.
Ответы (1)
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
Ответы (1)