Задать вопрос
1 октября, 00:55

Дана последовательность из N вещественных чисел. Переменной t присвоить значение true, если в последовательности нет нулевых элементов. Написать программу для Pascal ABC и блок-схему. Студенческий уровень.

+1
Ответы (1)
  1. 1 октября, 04:29
    0
    Var

    N, i: integer;

    x: real;

    t: boolean;

    begin

    readln (N) ;

    i : = 0;

    repeat

    i : = i + 1;

    Readln (x) ;

    until (x < 0.001) or (i = N) ;

    t : = x > 0.001;

    writeln (t)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность из N вещественных чисел. Переменной t присвоить значение true, если в последовательности нет нулевых элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан алгоритм: Начало Присвоить a значение 1 Присвоить b значение 1 Присвоить c значение 0 Пока a меньше чем 1001 Начало цикла Присвоить b значение b * a Присвоить a значение a + 1 Конец цикла Пока b делится на 6 Начало цикла Присвоить c значение c +
Ответы (1)
Выберите логическое выражение, принимающее значение True a) (True and True) and (False or False) b) Not (True and Not False) or False c) (True or False) or Not (True and True) d) Not (True or False) and True
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. На входе непустая последовательность натуральных чисел с нулем в конце. Вывести MIN и среднее арифметическое. Представить блок-схему и pascal-программу. 2. На входе последовательность вещественных чисел с нулем в конце.
Ответы (1)
Даны две числовые переменные a и b. Необходимо присвоить переменной a значение переменной b, переменной b необходимо присвоить значение переменной a, без использования дополнительных переменных.
Ответы (1)