Задать вопрос
16 июля, 14:17

Напишите программу реализующую калькулятор на 4 арифметических действия. На языке паскаль

+3
Ответы (1)
  1. 16 июля, 15:29
    0
    Program test;

    var

    a, b:integer;

    rezultat:real;

    sign:char;

    begin

    rezultat:=0;

    writeln ('Введите числа a, b: ') ;

    readln (a, b) ;

    writeln ('Введите знак операции: ') ;

    readln (sign) ;

    case sign of

    '+': rezultat:=a+b;

    '-': rezultat:=a-b;

    '*': rezultat:=a*b;

    '/': rezultat:=a/b else writeln ('An error occurred: Invalid operation! Try again!') ;

    end;

    writeln (rezultat) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу реализующую калькулятор на 4 арифметических действия. На языке паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Написать программу на языке Паскаль, реализующую следующую задачу: Продаются товары двух видов. Запросить с клавиатуры для каждого товара цену, количество в начале рабочего дня и количество проданного товара (и одного и другого) за день.
Ответы (1)
Написать реализующую алгоритм программу на языке паскаль. Даны натуральные числа n и m. Получить сумму m последних цифр числа n. Числа n и m задаются пользователем
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)