Задать вопрос
30 апреля, 01:05

Распечатать числа от 1 до N, которые не имеют однозначных делителей (не равных числу).

Цикл while

+4
Ответы (1)
  1. 30 апреля, 04:49
    0
    Var n, k, m, i, j:integer;

    begin

    readln (n) ;

    for i:=1 to n do

    begin

    k:=0;

    if i<=9 then m:=i-1 else m:=9;

    for j:=2 to m do

    if i mod j = 0 then k:=k+1;

    if k=0 then write (i,' ') ;

    end;

    end.

    Пример:

    150

    1 2 3 5 7 11 13 17 19 23 29 31 37 41 43 47 53 59 61 67 71 73 79 83 89 97 101 103 107 109 113 121 127 131 137 139 143 149
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Распечатать числа от 1 до N, которые не имеют однозначных делителей (не равных числу). Цикл while ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сколько раз будет выполнен этот цикл? i:=2; while i
Ответы (2)
Проверить являются ли два введенных числа дружественными. Дружественные числа - пара чисел, каждое из которых равно сумме собственных делителей другого (Делителем числа называется всякий его делитель, отличный от самого числа) Дружественные числа
Ответы (1)
полностью заполненного картриджа лазерного принтера хватает, чтобы распечатать 1600 страниц при трехпроцентном заполнении страницы. После включения режима экономии тонера можно распечатать на 20% страниц больше.
Ответы (1)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
3) Определите, сколько раз исполнится цикл:for i:=0 to 8 do write (i) ; A) Цикл будет бесконечным B) Вообще не исполнится C) 8 раз D) 9 раз 4) Определите, сколько раз исполнится цикл:for i:=-10 downto 0 do write (i) ;
Ответы (1)