Задать вопрос
17 июня, 12:14

Паскаль.

Написать программу для расчёта произведения элементов одномерного массива.

(размер массива произвольный, элементы вводятся с клавиатуры)

+5
Ответы (1)
  1. 17 июня, 16:01
    0
    Program pr;

    var a:array [1 ... n] of integer;

    n, i, c: integer;

    begin

    c : = 1

    n : = random (50) ;

    for i : = 1 to n do

    begin

    readln (a[i]) ;

    c : = c * a[i];

    end;

    writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Написать программу для расчёта произведения элементов одномерного массива. (размер массива произвольный, элементы вводятся с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
Помогите решить задачу Найти сумму элементов одномерного массива. Размер произвольный. Элементы вводятся с клавиатуры.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)