Задать вопрос
7 октября, 23:23

Паскаль, по координатам трех вершин некоторого треугольника найдите его периметр, если такой треугольник существует

+1
Ответы (1)
  1. 8 октября, 02:26
    0
    Program n1;

    var kord: array[1 ... 6] of real;

    st: array [1 ... 3] of real;

    i: integer;

    begin

    i:=1;

    while i<=6 do

    begin

    write ('введите координаты точки через пробел: ') ;

    readln (kord[i], kord[i+1]) ;

    i:=i+2;

    end;

    st[1]:=sqrt (sqr (kord[3]-kord[1]) + sqr (kord[4]-kord[2])) ;

    st[2]:=sqrt (sqr (kord[5]-kord[1]) + sqr (kord[6]-kord[2])) ;

    st[3]:=sqrt (sqr (kord[5]-kord[3]) + sqr (kord[6]-kord[4])) ;

    if (st[1]< (st[2]+st[3])) and (st[2]< (st[1]+st[3])) and (st[3]< (st[1]+st[2])) then write ('P=', st[1]+st[2]+st[3]) else write ('треугольник не существует') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль, по координатам трех вершин некоторого треугольника найдите его периметр, если такой треугольник существует ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Напишите функцию, вычисляющую длину отрезка по координатам его концов. С помощью этой функции напишите программу на Pascal ABC, вычисляющую периметр треугольника по координатам его вершин
Ответы (1)
Вычислите алгоритмы: По координатам трех вершин некоторого треугольника найдите его площадь и периметр.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Найдите ошибки в программе (паскаль) program exmpl var C: char begin write ('Введите длины трех сторон треугольника: ') read (A, B, C) write ('Треугольник со сторонами ', a, b, c) if a + b > c and b + c > a and a + c > b then write ('существует.
Ответы (1)