Задать вопрос
27 января, 23:05

Составить программу для подсчета суммы нечетных чисел от 1 до n

+5
Ответы (1)
  1. 27 января, 23:16
    0
    Var s, i, n:integer;

    begin

    s:=0;

    readln (n) ;

    for i:=1 to n do

    if (i mod 2 0) then

    s+=i;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для подсчета суммы нечетных чисел от 1 до n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Тема:Pascal. Циклы 1) Составить программу подсчета суммы нечетных делителей, кратных трем, натурального числа N 2) Составить программу, вычисляющую x^n, где n-целое положительное число. 3) Одноклеточная амеба каждые 3 часа делится на 2 клетки.
Ответы (1)
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Составьте программу подсчета суммы четных и количества нечетных чисел от 1 до 200
Ответы (1)
1) Составте программу подсчета нулевых элементов одно мерного массива Т (И) стоящих на нечетных местах. 2) Сотавте программу, которая в одно мерном массиве А (18) все элементы с нечетными номерами меняется на 0.
Ответы (1)