Задать вопрос
9 мая, 22:24

1) Составте программу подсчета нулевых элементов одно мерного массива Т (И) стоящих на нечетных местах.

2) Сотавте программу, которая в одно мерном массиве А (18) все элементы с нечетными номерами меняется на 0.

+3
Ответы (1)
  1. 10 мая, 00:05
    0
    Const

    n = 20;

    var

    T: array[1 ... n] of integer;

    i, k: integer;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    k : = 0;

    for i : = 1 to n do

    begin

    T[i] : = Random (11) - 5;

    Write (T[i]:3) ;

    if ((i mod 2) 0) and (T[i]=0) then Inc (k) ;

    end;

    Writeln;

    Writeln ('Количество нулевых элементов на нечетных местах равно ', k) ;

    end.

    Тестовое решение:

    Элементы массива

    2 5 - 4 4 3 - 2 5 - 5 - 1 - 2 5 2 0 - 5 - 5 - 4 - 3 3 0 1

    Количество нулевых элементов на нечетных местах равно 2

    const

    n = 18;

    var

    T: array[1 ... n] of integer;

    i: integer;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    for i : = 1 to n do

    begin

    T[i] : = Random (51) - 25;

    Write (T[i]:4) ;

    end;

    Writeln;

    Writeln ('Результат') ;

    for i : = 1 to n do

    begin

    if ((i mod 2) 0) then T[i] : = 0;

    Write (T[i]:4) ;

    end;

    Writeln;

    end.

    Тестовое решение:

    Элементы массива

    23 - 6 8 14 15 12 - 24 20 - 11 - 7 4 - 24 22 - 19 12 - 6 21 17

    Результат

    0 - 6 0 14 0 12 0 20 0 - 7 0 - 24 0 - 19 0 - 6 0 17
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Составте программу подсчета нулевых элементов одно мерного массива Т (И) стоящих на нечетных местах. 2) Сотавте программу, которая в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Паскаль, помогите! В числовом массиве из 10 элементов, заданных случайным образом от - 100 до 500. Найти: 1) сумму положительных элементов, стоящих на чётных местах; 2) произведение элементов массива, кратных 3 и стоящих на нечётных местах;
Ответы (1)
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
Задача Pascal Найти наименьшие элементы в каждом столбце матрицы Х (5,5) и переписать их в одномерных массив А. В массиве А вычислить сумму элементов, стоящих на четных местах и произведение элементов, стоящих на нечетных местах.
Ответы (1)