Задать вопрос
21 августа, 09:39

Дана точка А (х, у). Определить, принадлежит ли она прямоугольнику с вершинами в точках (х1, у1), (х2, у2), (х3, у3), (х4, у4)

На Паскале

+2
Ответы (1)
  1. 21 августа, 12:23
    0
    Function sq (var x1, y1, x2, y2, x3, y3: real) : real;

    begin

    / / вычисляем площадь треугольника с помощью

    / / векторного произведения

    sq:=abs ((x2-x1) * (y3-y1) - (x3-x1) * (y2-y1)) / 2;

    end;

    / / основная программа

    var x, y, x1, y1, x2, y2, x3, y3, x4, y4, st, sp:real;

    begin

    write ('координаты 4 вершин x1 y1 x2 y2 x3 y3 x4 y4 через пробел: ') ;

    readln (x1, y1, x2, y2, x3, y3, x4, y4) ;

    sp:=2*sq (x1, y1, x2, y2, x3, y3) ;

    write ('координаты точки x y через пробел: ') ; readln (x, y) ;

    st:=sq (x1, y1, x2, y2, x, y) + sq (x2, y2, x3, y3, x, y) +

    sq (x3, y3, x4, y4, x, y) + sq (x4, y4, x1, y1, x, y) ;

    if abs (sp-st) <1.0e-9 then

    writeln ('точка принадлежит прямоугольнику')

    else writeln ('точка не принадлежит прямоугольнику') ;

    end.

    координаты 4 вершин x1 y1 x2 y2 x3 y3 x4 y4 через пробел: 1 4 6 9 9 6 4 1

    координаты точки x y через пробел: 4 7

    точка принадлежит прямоугольнику

    координаты 4 вершин x1 y1 x2 y2 x3 y3 x4 y4 через пробел: 1 4 6 9 9 6 4 1

    координаты точки x y через пробел: 1.5 1.6

    точка не принадлежит прямоугольнику
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана точка А (х, у). Определить, принадлежит ли она прямоугольнику с вершинами в точках (х1, у1), (х2, у2), (х3, у3), (х4, у4) На Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана фигура прямоугольника на координатной плоскости параллельно оси х у. Определить принадлежит ли эта точка прямоугольнику?
Ответы (1)
Написать программу на языке Паскаль Точка М (х, у) принадлежит прямоугольнику, ограниченному прямыми х=2, у=1 и координатными осями.
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Дана точка В с координатами x, y. Определить, в какой четверти координатной плоскости лежит данная точка В. Точка с координатами (-5; 5) очень строчно надо помогите соч за 3 четверть
Ответы (1)
Запишите на языке Pascal следующие условия: величина x - неотрицательна; 0 < x < 5; a < = 5 (меньше или равно) ; величины x и y - положительны; x > 0, y < = 5 (меньше или равно) ; x принадлежит [ 0; 4 ]; x принадлежит (-5; 5) ; x принадлежит [ 0;
Ответы (1)