Задать вопрос
17 мая, 07:09

Отсортировать элементы стоящие до последнего нечетного элемента массива по возрастанию методом выбора

Pascal ABC

+2
Ответы (1)
  1. 17 мая, 10:50
    0
    Const n=10;

    var i, j, mn, mnin, k, ind: integer;

    a: array[1 ... n] of integer;

    begin

    writeln ('исходный массив:') ;

    randomize;

    for i:=1 to n do

    begin

    a[i]:=random (-n, n) ;

    write (a[i],' ') ;

    if ((a[i] mod 2) 0) and (a[i]0) then ind:=i;

    end;

    writeln;

    / / сортировка

    for i:=1 to ind-2 do

    begin

    mn:=a[i]; mnin:=i;

    for j:=i to ind-1 do

    if a[j]
    begin

    mn:=a[j];

    mnin:=j;

    end;

    k:=a[i];

    a[i]:=a[mnin];

    a[mnin]:=k;

    end;

    writeln ('новый массив:') ;

    for i:=1 to n do write (a[i],' ') ;

    end.

    исходный массив:

    -10 - 1 - 5 3 - 7 - 10 1 1 - 6 4

    новый массив:

    -10 - 10 - 7 - 5 - 1 1 3 1 - 6 4

    исходный массив:

    -3 0 7 10 1 7 - 3 5 - 2 - 2

    новый массив:

    -3 - 3 0 1 7 7 10 5 - 2 - 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Отсортировать элементы стоящие до последнего нечетного элемента массива по возрастанию методом выбора Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Изменить массив таким образом, чтобы все элементы массива, стоящие до максимального элемента этого массива бы ли бы отсортированы по возрастанию элементы стоящие после него-по убыванию.
Ответы (1)