Задать вопрос
1 ноября, 06:29

1. По натуральному числу х выяснить следующее за ним число. 2. По двум натуральным числам Х и У дать ответ на вопрос:

Х>У Х=У Х<У

3. По натуральному числу вычислить х - 1, если это возможно по натуральным числам. 4. По двум натуральным числам вычислить х-у если это возможно. Иначе выдать "разность не имеет натуральное число". 5. По двум натуральным числам х и у найти их произведение. 6. По двум натуральным числам х и у найти частное и остаток при делении х/у.

Во всех случаях x=6, y=3

+5
Ответы (1)
  1. 1 ноября, 10:11
    0
    1.

    var x, m: integer;

    begin

    x : = 6;

    m : = x + 1;

    end.

    2.

    var x, y: integer;

    begin

    x : = 6;

    y : = 3;

    if x>y then writeln ('x>y - istinno')

    else writeln ('x>y - lozhno')

    if x=y then writeln ('x=y - istinno')

    else writeln ('x>y - lozhno')

    if x
    else writeln ('x>y - lozhno')

    end.

    3.

    1.

    var x, m: integer;

    begin

    x : = 6;

    if x-1>0 then m : = x - 1;

    end.

    4.

    var x, y, m: integer;

    begin

    x : = 6;

    y : = 3;

    if x-y>0 then m : = x - y

    else writeln ('raznost ne imeet naturalnoe chislo')

    end.

    5.

    var x, y, m: integer;

    begin

    x : = 6;

    y : = 3;

    m : = x * y;

    end.

    6.

    var x, y, m, n: integer;

    begin

    x : = 6;

    y : = 3;

    n : = x / y;

    m : = x mod y;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. По натуральному числу х выяснить следующее за ним число. 2. По двум натуральным числам Х и У дать ответ на вопрос: Х>У Х=У Х ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Преобразуйте следующее двоичное число в восьмеричное: 10011 2) Преобразуйте следующее двоичное число в десятеричное: 101100 3) Преобразуйте следующее двоичное число в шестнадцатеричное: 1011000111 4) Преобразуйте следующее восьмеричное число в
Ответы (1)
А. Составьте подпрограмму-функцию, которая по заданному натуральному числу n вычислит сумму его цифр. б. Составьте алгоритм, подсчитывающий количество n-значных натуральных чисел, у каждого из которых сумма цифр равна заданному натуральному числу k.
Ответы (1)
1) Преобразуйте следующее восьмеричное число в двоичное: 7267 2) Преобразуйте следующее восьмеричное число в десятичное 6706 3) Преобразуйте следующее восьмеричное число в шеснадцатиричное 61 4) Преобразуйте следующее десятичное число в двоичное 498
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Напишите эффективную программу, которая по двум данным натуральным числам m и n, не превосходящим 30000, подсчитывает количество натуральных чисел с последней цифрой 0 на отрезке [m, n] (включая концы отрезка) Программа получает на вход два
Ответы (1)