Задать вопрос
30 сентября, 19:16

Удалить в массиве предпоследний неотрицательный элемент

pascal abc

+3
Ответы (1)
  1. 30 сентября, 21:30
    0
    Const n=20;

    var i, k, m: integer;

    a: array[1 ... n] of integer;

    begin

    randomize;

    writeln ('исходный массив:') ;

    for i:=1 to n do

    begin

    a[i]:=random (-10,10) ;

    write (a[i],' ') ;

    end;

    writeln;

    k:=0; m:=0;

    for i:=n downto 1 do

    begin

    if a[i]>=0 then k:=k+1;

    if k=2 then

    begin

    m:=i; break;

    end;

    end;

    if m>0 then

    begin

    for i:=m to n-1 do a[i]:=a[i+1];

    writeln ('новый массив:') ;

    for i:=1 to n-1 do write (a[i],' ') ;

    end

    else writeln ('нет такого элемента') ;

    end.

    исходный массив:

    -9 - 3 8 - 10 7 7 6 10 4 - 2 - 10 7 - 1 - 3 10 - 4 2 10 7 - 5

    новый массив:

    -9 - 3 8 - 10 7 7 6 10 4 - 2 - 10 7 - 1 - 3 10 - 4 2 7 - 5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Удалить в массиве предпоследний неотрицательный элемент pascal abc ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Удаление повторяющихся чисел в массиве - Pascal ABC Удалить в массиве все числа которые повторяются более двух раз
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Удалить в массиве второй отрицательный элемент если такой есть pascal abc
Ответы (1)
написать программу на Pascal - В одномерном массиве целых чисел, содержащем 20 элементов, удалить k-ый элемент массива. Массив заполняется случайным образом числами от 0 до 50.
Ответы (1)