Задать вопрос
5 февраля, 03:29

Написать программу в Pascal.

Высота саженца 20 см. Естественный ежегодный прирост 15%. Через сколько лет высота достигнет 500 см?

+3
Ответы (1)
  1. 5 февраля, 05:18
    0
    Var h: real;

    n: integer;

    begin

    h:=20; n:=0;

    repeat

    h:=h*1.15;

    n:=n+1;

    until h>=500;

    writeln (n,' года') ;

    end.

    24 года
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Pascal. Высота саженца 20 см. Естественный ежегодный прирост 15%. Через сколько лет высота достигнет 500 см? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Запас рыбы в озере оценивается в А особей. Ежегодный прирост составляет 15%. Ежегодный отлов - В особей. Критической считается ситуация, когда особей становится меньше С. Через сколько лет нужно прекратить отлов, чтобы ситуация не стала критической?
Ответы (1)
Ежегодный прирост рыбы в пруду 15%. Запасы рыбы оценены в А тонн, ежегодный план отлова В тонн, наименьший запас, ниже которого запас уже не восстанавливается составляет С тонн. Сколько лет можно выдержать заданный план?
Ответы (1)
Запас рыбы в пруду оценен в А тонн. Ежегодный прирост рыбы составляет 15%. Ежегодный план отлова - В тонн. Наименьший запас рыбы составляет С тонн. (Запас ниже С тонн не восстанавливается.
Ответы (1)
Запасы рыбы оценены в А тонн. Ежегодный прирост рыбы в пруду 15%. ежегодный план отлова В тонн, наименьший запас рыбы составляет С тонн (запас ниже С тонн уже не восстанавливается).
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)