Задать вопрос
7 августа, 02:24

В четырёхзначном числе определить сколько в нём нулевых цифр, использовать паскаль

+1
Ответы (1)
  1. 7 августа, 02:58
    0
    Var

    N, i, P, O, Z : Integer;

    R : Real;

    begin

    Write ('n = ') ; ReadLn (N) ;

    P : = 0; O : = 0; Z : = 0;

    / / для for / / для while / / для repeat

    for i : = 1 to N do / / i : = 0; / / i : = 0;

    / / while i < N do / / repeat

    begin / / begin / / Inc (i)

    / / Inc (i) ;

    Write (i, ' число = ') ; ReadLn (R) ;

    case sign (R) of

    +1 : Inc (P) ;

    -1 : Inc (O) ;

    0 : Inc (Z) ;

    end;

    end; / / end; / / until i = N;

    WriteLn ('Процент положительных чисел: ', P*100/N) ;

    WriteLn ('Процент отрицательных чисел: ', O*100/N) ;

    WriteLn (' Процент нулевых чисел: ', Z*100/N) ;

    end.

    тут даже больше
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В четырёхзначном числе определить сколько в нём нулевых цифр, использовать паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Дан массив из N целочисленных элементов. найти максимальное количество подряд идущих нулевых элементов. Гарантируется, что в массиве есть хотя бы одна пара рядом стоящих нулевых элементов.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)