Задать вопрос
28 июня, 07:48

Найти наименьшее общее кратное трех натуральных чисел в Pascal

+2
Ответы (1)
  1. 28 июня, 11:06
    0
    Var a, b, c: integer;

    begin

    write ('Введите a:') ;

    readln (a) ;

    write ('Введите b:') ;

    readln (b) ;

    write ('Введите c:') ;

    readln (c) ;

    for var i: = 2 to min (min (a, b), c) do

    begin

    if (a mod i = 0) and (b mod i = 0) and (c mod i = 0) then

    begin

    writeln ('НОК для ', a,' ', b,' ', c,' равен : ', i) ;

    break;

    end

    else

    begin

    writeln ('для ', a,' ', b,' ', c,' не существует НОК') ;

    break;

    end

    end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти наименьшее общее кратное трех натуральных чисел в Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Pascal. Даны четыре натуральных числа. Найти наименьшее общее кратное (НОК) для этих четырех чисел. Поиск НОК двух чисел оформить функцией.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5.
Ответы (1)