Задать вопрос
5 августа, 14:27

Решить в Паскале: Последовательно вводятся N целых чисел. Определить, каких среди них чисел больше: положительных или отрицательных.

+5
Ответы (2)
  1. 5 августа, 16:35
    0
    Const

    nn=100;

    var

    i, n, d:integer;

    a:array[1 ... nn] of integer;

    begin

    Write ('n = ') ; Read (n) ;

    Randomize;

    d:=0;

    for i:=1 to n do begin

    a[i]:=Random (21) - 10;

    Write (a[i],' ') ;

    if a[i]>0 then d:=d+1

    else

    if a[i]<0 then d:=d-1

    end;

    Writeln;

    if d>0 then Writeln ('Положительных чисел больше')

    else

    if d<0 then Writeln ('Отрицательных чисел больше')

    else Writeln ('Положительных и отрицательных поровну')

    end.

    Пример

    n = 13

    -1 - 5 3 - 3 - 4 - 8 1 6 4 7 - 7 10 7

    Положительных чисел больше
  2. 5 августа, 17:57
    0
    Var

    cnt1, cnt2, n, tmp:integer;

    begin

    Readln (N) ;

    while n > 0 do

    begin

    n: = n - 1;

    Read (tmp) ;

    if tmp > 0 then cnt1: = cnt1 + 1;

    if tmp < 0 then cnt2: = cnt2 + 1;

    end;

    if cnt1 > cnt2 then Writeln ('Положительных больше')

    else if (cnt1 = cnt2) then writeln ('Одинаковое количество')

    else Writeln ('Отрицательных больше') ;

    end.

    Пример:

    4

    -1 - 1 - 1 1

    Отрицательных больше
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить в Паскале: Последовательно вводятся N целых чисел. Определить, каких среди них чисел больше: положительных или отрицательных. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Вводятся 4 числа целого типа : a b c d. определить наибольшее среди них. 2. последовательно вводятся N целых чисел. найти сумму всех отрицательных среди них.
Ответы (1)
Pascal, цикл для, составить программу. 3) Последовательно вводятся 10 целых чисел. Определить каких среди них больше: положительных или отрицательных.
Ответы (1)
Помогите составить программу с оператором while вводятся 5 чисел. определить, сколько среди них положительных (включая 0) и сколько отрицательных. (числа вводятся в одну переменную в цикле).
Ответы (1)
помогите решить три номера! 1. Вычислите сумму данных 100 натуральных чисел. Вводятся 100 чисел, сумму которых необходимо посчитать. 2. Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. 3.
Ответы (1)
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)