Задать вопрос
5 ноября, 09:41

Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры

+3
Ответы (1)
  1. 5 ноября, 10:18
    0
    Прости, что отвечаю через 2 часа, был не дома)

    var

    i, j, n : integer;

    flag : boolean;

    begin

    write ('n = ') ;

    read (n) ;

    for i : = 2 to n do begin

    flag : = true;

    for j : = 2 to i-1 do

    if (i mod j = 0) then begin

    flag:=false;

    break;

    end;

    if flag = true then write (i, ' ') ;

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1. Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры. 2. Напишите функцию, которая находит наибольший общий делитель для двух заданных чисел.
Ответы (1)
Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры. Напишите функцию, которая находит наибольший общий делитель для двух заданных чисел.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)