Задать вопрос
12 июля, 05:24

Задано четыре числа: a, b, c, d. Требуется разбить их на две пары, чтобы сумма произведений в этих парах была максимальна

Например, если заданы числа 2,3,4 и 5, то оптимально разбить их на пары (2,3) и (4,5), в этом случае искомая сумма равна 2x3+4x5=26.

Формат входных данных

На вход подаются четыре числа: a. b. c и d. Все числа по модулю не превышают 1000 ...

Формат выходных данных.

Выведите искомую максимальную сумму.

Примеры

стандартный ввод

2 3 4 5

стандартный вывод

26

+4
Ответы (2)
  1. 12 июля, 05:50
    0
    Var a: array[1 ... 4] of integer;

    i, j: integer;

    begin

    for i:=1 to 4 do read (a[i]) ;

    for i:=1 to 3 do

    for j:=i+1 to 4 do

    if a[i]
    writeln (a[1]*a[2]+a[3]*a[4]) ;

    end.

    11 6 5 19

    239
  2. 12 июля, 07:28
    0
    Var a, b, c, d, s:integer;

    begin

    readln (a, b, c, d) ;

    s:=a*b+c*d;

    if a*c+b*d>s then s:=a*c+b*d;

    if a*d+b*c>s then s:=a*d+b*c;

    writeln (s) ;

    / / можно вывести полученные пары чисел:

    if s=a*b+c*d then writeln (' (', a,',', b,') и (', c,',', d,') ')

    else if s=a*c+b*d then writeln (' (', a,',', c,') и (', b,',', d,') ')

    else writeln (' (', a,',', d,') и (', b,',', c,') ')

    end.

    Пример:

    2 3 4 5

    26

    (2,3) и (4,5)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задано четыре числа: a, b, c, d. Требуется разбить их на две пары, чтобы сумма произведений в этих парах была максимальна Например, если ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите рекурсивную функцию вычисления суммы цифр натурального числа. Формат входных данных На вход ваша программа получает одно натуральное число n (n
Ответы (1)
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Ответы (1)
Задача D Нечет Задано два целых числа A и B. Найдите сумму нечетных чисел от A до B. Формат входных данных Первая строка входного файла содержит два целых числа A и B (1 < = A, B < = 10^9). Формат выходных данных Выведите ответ к задаче.
Ответы (1)
С некоторого момента прошло N дней. Сколько полных недель прошло за этот период. Формат входных данных На вход программе подается 0≤N≤106. Формат выходных данных Вывести целое число - ответ на вопрос. Примеры: Вход 100 Выход 14
Ответы (1)
Напишите рекурсивную функцию подсчёта количества цифр в натуральном числе. Формат входных данных На вход ваша программа получает одно натуральное число n (1≤n≤216-11≤n≤216-1). Формат выходных данных Выведите одно число - количество цифр в числе n.
Ответы (2)