Задать вопрос
12 июля, 01:41

Написать программу с использованием оператора while do

Портному принесли кусок ткани длиной 400 метров, на одну занавеску требуется 3 метра ткани, рассчитать сколько занавесок получится и остаток также, учитывая, что портной не умеет делить, а только складывать и вычитать

+5
Ответы (1)
  1. 12 июля, 02:25
    0
    Program portnoy;

    var L, k : integer;

    begin

    L=400;

    k=0;

    While L>=3 do begin

    L=L-3;

    k=k+1;

    end;

    WriteLn (' получится ', k,' занавесок и останется ', L,' метров ткани') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу с использованием оператора while do Портному принесли кусок ткани длиной 400 метров, на одну занавеску требуется 3 метра ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Разработайте алгоритм перемножения двух целых чисел без применения операции умножения (для особого компьютера, который умеет только вводить, выводить, складывать, вычитать и сравнивать числа). Выполнить в виде псевдокода
Ответы (1)
1) Вывести Чётные числа с 18 до 62 с использованием оператора цикла "for" 2) Вывести нечётные числа в обратном порядке с 31 до 1 с использованием оператора цикла "for".
Ответы (1)
Написать программу с использованием оператора while в результате работы которой осуществляется вывод последовательности чисел 1 2 3 4 5
Ответы (1)
Написать программу с использованием оператора while в результате работы которой осуществляется вывод последовательности чисел 9 7 5 3 1
Ответы (1)