Задать вопрос
4 декабря, 08:22

Исходные данные: Дан целлочисленные массв размером М вывести все содержащиеся в данном масиве отрицательного числа в порядке убывания их индексов, а также их количестве

+2
Ответы (1)
  1. 4 декабря, 11:10
    0
    Const m=10;

    var a:array[1 ... m] of integer;

    i, k:integer;

    begin

    Randomize;

    for i:=1 to m do begin

    a[i]:=random (21) - 10;

    write (a[i],' ') ;

    end;

    writeln;

    k:=0;

    for i:=m downto 1 do

    if a[i]<0 then begin k:=k+1; write (a[i],' ') ; end;

    writeln;

    writeln ('k = ', k) ;

    end.

    Пример:

    4 2 5 - 6 0 - 10 8 - 1 2 - 9

    -9 - 1 - 10 - 6

    k = 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Исходные данные: Дан целлочисленные массв размером М вывести все содержащиеся в данном масиве отрицательного числа в порядке убывания их ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан целочисленный массив размером N. Вывести вначале все содержащиеся в данном массиве четные числа в порядке возрастания их индексов, а затем - все нечетные в порядке убывания их индексов (если можно еще блок схему (не обязательно))
Ответы (1)
Дан целочисленный массив размера 20, числовые значения которого вводятся с клавиатуры. Вывести все содержащиеся в данном массиве начетные числа в порядке убывания их индексов, а также их количество.
Ответы (1)
Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна содержаться сумма индексов.
Ответы (1)
Дан целочисленный массив размера N. Вывести все содержащиеся в данном массиве чётные числа в порядке возрастания их индексов, а также их количество k
Ответы (1)
Напишите программу, которая сортирует одномерный массив. Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна
Ответы (1)