Задать вопрос
20 октября, 10:20

Даны сумма и разность двух целых чисел. Нужно найти эти числа. НА PascalABC

+2
Ответы (1)
  1. 20 октября, 11:00
    0
    Сначала решим эту задачу математически.

    Пусть даны сумма двух чисел a и их разность b, сами числа x и y неизвестны

    составим систему:

    x+y=a

    x-y=b

    решим ее относительно a и b

    x=a-y

    a-y-y=b

    a-2y=b

    2y=a-b

    y = (a-b) / 2

    x=a - (a-b) / 2 = (2a-a+b) / 2 = (a+b) / 2

    теперь составляем программу:

    Program n1;

    var a, b: integer;

    begin

    write ('Введите сумму 2 целых чисел: ') ;

    readln (a) ;

    write ('Введите разность 2 целых чисел: ') ;

    readln (b) ;

    writeln ('1 число: ', (a+b) / 2) ;

    write ('2 число: ', (a-b) / 2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны сумма и разность двух целых чисел. Нужно найти эти числа. НА PascalABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
Помогите нужно использовать программу PascalABC Вариант 2 Программа PascalABC Кровяное давление у старшеклассников считается нормальным, если верхняя его граница H ≤ 100, а нижняя h ≥ 60 и H-h ≥ 30.
Ответы (1)
Помогите решить задачу в PascalABC 1) Даны два числа. Найти сумму их десятков и сумму их единиц. 2) Дано число. Проверить, делится ли оно на 2, на 3 или на 5.
Ответы (1)
Нужно написать программу на PascalABC Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
10 я - 4; 2 я - ?; 8 я-?; 16 я-?; сумма - 100+1100=?; разность-1100-100=?; 10 я - 19; 2 я-?; 8 я-?; 16 я-?; сумма - 10011 + 111001=?; разность 111001-10011=?; 10 я-34; 2 я-?; 8 я-?; 16 я-?; сумма-10010+1100110=?; разность-1100110-100010=?
Ответы (1)