Задать вопрос
24 июня, 07:26

Помогите решить задачу в PascalABC

1) Даны два числа. Найти сумму их десятков и сумму их единиц.

2) Дано число. Проверить, делится ли оно на 2, на 3 или на 5.

3) Найти разность пятизначного числа и числа, записанного этими же цифрами в обратном порядке.

+3
Ответы (1)
  1. 24 июня, 09:55
    0
    1) var a, b:integer;

    begin

    readln (a, b) ;

    writeln ('Сумма единиц: ', a mod 10+b mod 10) ;

    writeln ('Сумма десятков: ', (a div 10) mod 10 + (b div 10) mod 10) ;

    end.

    2) var a:integer;

    begin

    readln (a) ;

    if a mod 2=0 then writeln ('Делится на 2') else writeln ('Не делится на 2') ;

    if a mod 3=0 then writeln ('Делится на 3') else writeln ('Не делится на 3') ;

    if a mod 5=0 then writeln ('Делится на 5') else writeln ('Не делится на 5') ;

    end.

    3) var a, b, c:integer;

    begin

    readln (a) ;

    c:=a;

    while a>0 do begin

    b:=10*b+a mod 10;

    a:=a div 10;

    end;

    writeln (c-b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу в PascalABC 1) Даны два числа. Найти сумму их десятков и сумму их единиц. 2) Дано число. Проверить, делится ли оно ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Найти разность пятизначного числа и числа, записанного этими же цифрами в обратном порядке
Ответы (1)
Напишите программу на паскале, которая 1) сначала определит по введенному двузначному числу цифру десятков и цифру единиц. 2.1) Если цифра десятков меньше цифры единиц, то программа выведет двузначное число, состоящее из. цифр единиц.
Ответы (1)
Помогите решить задания: (делать в условном операторе) 1. Даны 2 числа а и b, найти разность между большим и меньшим из этих чисел. 2.
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
Помогите нужно использовать программу PascalABC Вариант 2 Программа PascalABC Кровяное давление у старшеклассников считается нормальным, если верхняя его граница H ≤ 100, а нижняя h ≥ 60 и H-h ≥ 30.
Ответы (1)