Задать вопрос
31 октября, 22:06

Паскаль.

Вообще нужна программа в которую например вводишь число 120

и она говорит это число трехзначное или например 90

это число двухзначное

+3
Ответы (1)
  1. 1 ноября, 01:12
    0
    Program dshvedkov;

    var

    n, k:integer;

    begin

    Write ('n=') ; Read (n) ;

    k:=0;

    n:=Abs (n) ; / / От минуса, иначе эта строка не нужна

    while n>0 do begin

    k:=k+1;

    n:=n div 10

    end;

    Writeln ('Число ', k,'-значное')

    end.

    Пример

    n=120

    Число 3-значное
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Вообще нужна программа в которую например вводишь число 120 и она говорит это число трехзначное или например 90 это число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Вычислите произведение всех целых чисел, расположенных за минимальным значением. нужна программа для open office как объяснила мне препод: вводишь произвольное количество чисел (допустим 6 чисел), с помощью формулы "min" вычислить минимальное ...
Ответы (1)
Помогите решите задачу! На языке pascal: пирожок стоит а гривен и б копеек. Определите сколько гривен и копеек надо заплатить за н пирожков Ты вводишь стоимость пирожка (гривны и копейки) и количество пирожков.
Ответы (1)
Питон (7 класс). Написать программу: "Сортировка цифр по убыванию в трёхзначном числе". Например: Вводишь число 149 - программа выдаёт тебе 841.
Ответы (1)