Задать вопрос
20 марта, 12:35

Известно количество страниц в статье. Составить программу нахождения стоимости издательских услуг, если среднее количество символов на странице 6020; а цена 1 страницы варьируется от их общего числа: от 1 до 3 - 100 рублей; от 4 до 6 - 90 рублей; больше 6 - 80 рублей.

+3
Ответы (1)
  1. 20 марта, 15:17
    0
    var n, s:integer;

    begin

    readln (n) ;

    case n of

    1 ... 3: s:=n*100;

    4 ... 6: s:=n*90;

    else s:=n*80;

    end;

    writeln ('Стоимость услуг: ', s,' руб.') ;

    end.

    Пример:

    5

    Стоимость услуг: 450 руб.

    PS. Количество символов на странице - лишняя информация здесь.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Известно количество страниц в статье. Составить программу нахождения стоимости издательских услуг, если среднее количество символов на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Издательства измеряют количество информации в учетно-издательских листах. Один такой лист включает 40000 знаков. Представьте количество информации в 12 издательских листах в битах и байтах.
Ответы (1)
1) Сколько символов в тексте, если 1) Сколько символов в тексте, если мощность алфавита-64 символа, а объем информации, содержащийся в нем-1,5 Кбайт. 2) Сообщение занимает 3 страницы по 25 строк. В каждой строке записано по 60 символов.
Ответы (1)
Сообщение на языке Хинь (50 символов в алфавите) занимает 5 страниц, по 30 строк на странице и по 60 символов в строке. Сообщение на языке Хань (70 символов в алфавите) занимает 4 страницы по 25 строк, 70 символов в строке.
Ответы (1)
Известно количество символов в каждой строке, количество строк на странице. Написать программу, считывающую эти значения с клавиатуры и вычисляющую число символов на странице.
Ответы (1)
1. Приветствие участникам олимпиады от лунных человечков записано с помощью всех символов лунного алфавита: ЮМА_ЮМ. Сколько информации оно несет? 2. Сообщение занимает 6 страниц по 35 строк. В каждой строке записано по 50 символов.
Ответы (2)