Задать вопрос
9 июля, 12:02

Написать программу в Паскале. Заполнить массив случайными величинами от - 100 до 100. Найти сумму элементоав массива.

+4
Ответы (1)
  1. 9 июля, 12:19
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    i, s:integer;

    begin

    Randomize;

    writeln ('Массив A:') ;

    for i:=1 to n do

    begin

    a[i]:=random (201) - 100;

    write (a[i]:4) ;

    end;

    writeln;

    s:=0;

    for i:=1 to n do s:=s+a[i];

    writeln ('s = ', s) ;

    end.

    Пример:

    Массив A:

    71 - 39 57 33 52 - 96 77 - 79 - 71 - 79

    s = - 74
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Паскале. Заполнить массив случайными величинами от - 100 до 100. Найти сумму элементоав массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу обработки двумерного массива: дан массив А 15 строк и 15 столбцов. Заполнить массив случайными числами, найти мах, мин, и сумму элементов всего массива Нужно в тетраде написать Нужно написать так, как в паскале
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество. 2. Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50.
Ответы (1)
1. Массив из 25 элементов заполнить случайными числами из диапазона [-100 ... 100] и вывести на экран. Найдите элемент массива с максимальной суммой цифр. 2. Массив из 20 элементов заполнить случайными числами из диапазона [1 ...
Ответы (1)