Задать вопрос
5 декабря, 05:53

Задача: Дано 2-х значное число, опредилить равен ли квадрат этого чиста учетверенной сумме кубов его цифр. Вопрос: Как решить эту задачу в Free Pascal?

+3
Ответы (2)
  1. 5 декабря, 07:18
    0
    var a, a1, a2, k, l:integer;

    begin

    writeln ('Введите число а')

    read (a) ;

    a1:=a mod 10;

    k:=a div 10;

    a2:=k mod 10;

    k:=a*a;

    l:=4 * (a1*a1*a1+a2*a2*a2) ;

    if (k=l) then

    writeln ('Равен')

    else writeln ('Нет') ;

    end.
  2. 5 декабря, 09:03
    0
    Var N, sum: integer;

    begin

    write ('Введите число: ') ; readln (N) ;

    sum : = ((N div 10) * (N div 10) * (N div 10) + (N mod 10) * (N mod 10) * (N mod 10)) * 4;

    if sum = sqr (N) then writeln ('Равно')

    else writeln ('Не равно') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача: Дано 2-х значное число, опредилить равен ли квадрат этого чиста учетверенной сумме кубов его цифр. Вопрос: Как решить эту задачу в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Дано двухзначное число определить равен ли квадрат этого числа учетверенной сумме кубов его цифр например для числа 48 положительный для числа 52 отрицательный в pascal
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)