Задать вопрос
1 октября, 22:34

Висящие вешалки Мишу не устроили, и он решил создать арт-объект. Он повесил одну вешалку, а на ее перекладину - ещё две, получился арт-объект. Ему показалось мало, и он стал вешать на перекладину нижней вешалки ещё по две. В итоге у него получилось n этажей. Напишите программу, которая определит, сколько вешалок понадобилось ямище для создания арт-объекта. Входные данные: n<=100 Выходные данные: вывести одно число - количество необходимых вешалок. Пример: Вх.: 3, Вых.: 7

+4
Ответы (1)
  1. 2 октября, 00:19
    0
    Можно просто вычислить 2^n-1 или (если не использовать функцию возведения в степень) сделать так:

    var n, i:integer; k:real;

    begin

    readln (n) ;

    k:=1;

    for i:=1 to n do k:=k*2;

    writeln (k-1) ;

    end.

    Пример:

    3

    7
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Висящие вешалки Мишу не устроили, и он решил создать арт-объект. Он повесил одну вешалку, а на ее перекладину - ещё две, получился ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Ответы (1)