Задать вопрос
31 июля, 20:15

2. Определить сколько раз будет выполняться цикл с параметром.

А) For i:0 to 4 do

Б) For i:=5 downto 2 do

В) For i:=5 to 1 do

Г) For i:=-1 to 1 do

+2
Ответы (1)
  1. 31 июля, 23:29
    0
    А) 5 раз

    i=0; i=1; i=2; i=3; i=4

    Б) 4 раза

    i=5; i=4; i=3; i=2

    В) Цикл не запустится так первоначальное значение больше конечного

    Г) 3 раза

    i=-1; i=0; i=1

    for i to - увеличивает значение i на 1 до конечного значения

    for i downto - уменьшает значение i на 1 до конечного
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2. Определить сколько раз будет выполняться цикл с параметром. А) For i:0 to 4 do Б) For i:=5 downto 2 do В) For i:=5 to 1 do Г) For i:=-1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Определить сколько раз выполнится цикл 1) For i:=2 to 3 do k:=k-1; 2) For i:=9 to 7 do k:=k+1; 3) For i:=5 to 2 do k:=k-1; 4) For i:=15 downto 4 do k:=k-1; 5) For i:=8 downto 10 do k:=k*10; 6) For i:=5 downto 3 do k:=т+3;
Ответы (1)
3) Определите, сколько раз исполнится цикл:for i:=0 to 8 do write (i) ; A) Цикл будет бесконечным B) Вообще не исполнится C) 8 раз D) 9 раз 4) Определите, сколько раз исполнится цикл:for i:=-10 downto 0 do write (i) ;
Ответы (1)
1. Определите сколько раз будет выполняться тело цикла, при вычислении:y=5x+12a на промежутке [-6; 6 ] с шагом 2. 2. Определите сколько раз будет выполняться тело цикла, при вычислении:y=7/12a на промежутке [-2; 1 ] с шагом 0,5. 3.
Ответы (1)
Сколько раз выполнится тело цикла? 1) For x:=3 to 8 do write ('*') ; 2) For x:=1 to 1 do write ('*') ; 3) For x:=5 to 3 do write ('*') ; 4) For x:=7 downto 4 do write ('*') ; 5) For x:=2 downto 2 do write ('*') ; 6) For x:=4 downto 9 do write ('*') ;
Ответы (1)
Цикл с параметром и шагом - 1 объявляется с использованием конструкции a) for i:=i1 downto i2 do begin ... end; b) repeat begin ... end until (выражение_условие) ; c) for i:=i1 to i2 do begin ... end; d) if (выражение_условие) begin ...
Ответы (1)