Задать вопрос
28 октября, 17:02

Напишите программу, которая возводит в четвёртую степень введённое с клавиатуры целое число. Составьте алгоритм решения этой задачи из нескольких операторов присваивания. В Pascal.

+1
Ответы (1)
  1. 28 октября, 18:02
    0
    var a, a2, a4:integer;

    begin

    readln (a) ;

    a2:=a*a;

    a4:=a2*a2;

    writeln (a,'^4 = ', a4) ;

    end.

    Пример:

    3

    81
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая возводит в четвёртую степень введённое с клавиатуры целое число. Составьте алгоритм решения этой задачи из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Если целое число М, введенное с клавиатуры, делится на целое число Н, введенное с клавиатуры, с остатком равным 2, то вывести на экран целую часть от деления М на Н, в противном случае - сообщение "при делении ... на ... остаток не равен 2"
Ответы (1)
Pascal abc Напишите программу, которая возводит в квадрат введенное целое число, если оно отрицательное, и выводит на экран результат.
Ответы (2)
1. Дано целое число c. Напишите программу, которая возводит в квадрат частное от целочисленного деления числа c на 5 и выводит на экран монитора результат. 2. Дано целое число c.
Ответы (1)
1) Проверка условия и ветвление в алгоритме. Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран: а) удвоенное значение числа, если число положительное; б) абсолютное значение числа, если число отрицательное.
Ответы (1)
Напишите программу, которая возводит в квадрат трехзначное число, введённое с клавиатуры, при условии, что в числе содержится цифра 7. Если в числе нет цифры 7, то следует вывести число в исходном виде (через оператор if) Паскаль
Ответы (1)