Задать вопрос
24 января, 04:08

Найти площадь (S) треугольника, если известны длины всех 3-х сторон этого треугольника. Длины сторон a, b, c вводятся пользователем с клавиатуры.

+2
Ответы (1)
  1. 24 января, 08:04
    0
    Uses crt;

    var a, b, c:integer;

    S, P:real;

    begin

    writeln ('Ведите a=') ; readln (a) ;

    writeln ('Ведите b=') ; readln (b) ;

    writeln ('Ведите c=') ; readln (c) ;

    P: = (a*b*c) / 2;

    S:=sqrt (P * (P-a) * (P-b) * (P-c)) ;

    writeln ('S=', S) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти площадь (S) треугольника, если известны длины всех 3-х сторон этого треугольника. Длины сторон a, b, c вводятся пользователем с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
Задания по Pascal №1 найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B. A и B вводятся с клавиатуры. №2 найти сумму всех чисел из промежутка от A до B, кратных 5. A и B вводятся с клавиатуры.
Ответы (1)
Пользователем с клавиатуры вводится цифровой код (1 или 2). Если код равен 1, то вводится длина ребра куба и находится общая площадь поверхностей граней куба, а если 2, то вводятся катеты прямоугольного треугольника и находится его площадь.
Ответы (1)