Задать вопрос
19 ноября, 19:42

Будьте добры, помогите с задачей в Паскале! Желательно с объяснением)

Пользователь водит 5 чисел. Записать их в порядке возрастания в одну строку через запятую.

+2
Ответы (1)
  1. 19 ноября, 22:01
    0
    Const n = 5; //константа

    var

    a:array [1 ... n] of integer; //массив под 5 чисел

    i, x, j:integer;

    begin

    for i: = 1 to n do / / ввод чисел

    begin

    readln (a[i]) ;

    end;

    writeln ('Числа в порядке возрастания: ') ;

    for i: = 1 to n do / / сортировка массива

    for j: = 1 to n do

    begin

    if (a[i]
    begin

    x:=a[i];

    a[i]:=a[j];

    a[j]:=x;

    end;

    end;

    for j: = 1 to n do / / вывод чисел

    if j 5 then write (a[j]+',') else

    write (a[j]) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Будьте добры, помогите с задачей в Паскале! Желательно с объяснением) Пользователь водит 5 чисел. Записать их в порядке возрастания в одну ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какое событие наступит после того, как: А) ученик встретит учителя Б) пользователь выберет команду меню В) пользователь выберет объект правой кнопкой мыши Г) пользователь включит компьютер Д) пользователь перетянет левый нижний угол окна
Ответы (1)
Напишите программу в паскале, которая будет вычислять сумму N целых чисел. Количество чисел N и сами числа пользователь водит с клавиатуры. Окно вывода: Введите количество чисел для сложения: 3 1 число: 9 2 число: 3 3 число: 1 Сумма = 13
Ответы (1)
Я что-то не догоняю. Помогите решить. Пользователь работал с каталогом С:/Физика/Задачи/Кинематика. Сначала он поднялся на один уровень вверх, затем еще раз поднялся на один уровень вверх и после этого спустился в каталог Экзамен.
Ответы (1)
Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36).
Ответы (1)
1. Пользователь находился в каталоге Наука. Затем он поднялся на три уровня вверх и оказался в каталоге Выставка.
Ответы (1)