Задать вопрос
16 июня, 11:17

Реализовать программу, осуществляющую вывод решения квадратного уравнения (параметры a, b, c вводятся с клавиатуры) Хелп ми!

+2
Ответы (2)
  1. 16 июня, 12:26
    0
    Program z1;

    var a, b, c:integer;

    begin

    readln (a, b, c) ;

    if (b*b-4ac) >0 then

    writeln ((-b+sqr (b*b-4ca)) / 4a, (-b-sqr (b*b-4ca)) / 4a)

    end.
  2. 16 июня, 14:09
    0
    Program kvadratnoe;

    var a, b, c, d:real;

    begin

    Writeln ('Введите коэффициенты:a, b, c') ;

    readln (a, b, c) ;

    d:=b*b-4*a*c; if d >0 then

    begin

    Writeln ('x1=', (-b-Sqrt (d)) / 2*a) ;

    Writeln ('x2=', (-b+Sqrt (d)) / 2*a)

    end;

    if d=0 then Writeln ('x=', (-b/2*a)) ;

    if d<0 then Writeln ('Действительных корней нет')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Реализовать программу, осуществляющую вывод решения квадратного уравнения (параметры a, b, c вводятся с клавиатуры) Хелп ми! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Как установить левое поле страницы в 2,5 см? (MS Excel) Файл - Параметры страницы ... - Поля - левое - 2,5 - Сохранить Файл - Параметры страницы ... - Поля - Сохранить Файл - Параметры страницы ...
Ответы (1)