Задать вопрос
6 декабря, 16:11

В массиве A = (a1, а2, ..., аn) удалить все подряд идущие отрицательные элементы, идущие вслед за минимальным элементом массива. (Программа с использованием массива и цикла for) Паскаль

+4
Ответы (1)
  1. 6 декабря, 17:17
    0
    Var

    a, b: array[1 ... 110000] of integer;

    i, n, j, cnt, min: integer;

    fl: boolean;

    begin

    Readln (n) ;

    for i : = 1 to n do

    Read (a[i]) ;

    min: = a[1];

    j: = 1;

    for i : = 2 to n do

    if a[i] < min then

    begin

    min: = a[i];

    j: = i;

    end;

    fl : = true;

    for i: = 1 to j do

    write (a[i], ' ') ;

    for i: = j + 1 to n do

    begin

    if a[i] > 0 then fl : = false;

    if (a[i] < 0) and (fl) then continue;

    write (a[i], ' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве A = (a1, а2, ..., аn) удалить все подряд идущие отрицательные элементы, идущие вслед за минимальным элементом массива. (Программа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Задача на C# В массиве A = (a1, а2, ..., аn) удалить все отрицательные элементы, стоящие перед минимальным элементом массива
Ответы (1)
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)