Задать вопрос
5 сентября, 21:43

Найти произведение P=2^3*4^3*6^3*8^3 ... Умножение выполнять до тех пор пока множитель не станет больше 500.

+1
Ответы (1)
  1. 5 сентября, 23:23
    0
    Var a, m:integer; p:real;

    begin

    p:=1;

    a:=0;

    m:=0;

    while m<=500 do

    begin

    a:=a+2;

    m:=a*a*a;

    p:=p*m;

    end;

    writeln (a,'^3 = ', m) ;

    writeln ('p = ', p) ;

    end.

    Результат:

    8^3 = 512

    p = 5.662310400000000e+07
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти произведение P=2^3*4^3*6^3*8^3 ... Умножение выполнять до тех пор пока множитель не станет больше 500. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выведите на экран четные числа до тех пор пока их произведение не станет больше заданного числа. в паскаль.
Ответы (1)
С клавиатуры вводится числа и находится их произведение до тех пор пока произведение чисел не привести 10 000. Посчитайте количество введенных чисел и полученное произведение.
Ответы (1)
Написать программу 4. Компьютер перебирает четные числа до тех пор, пока сума их квадратов не превысит S. Чему равна сумма квадратов? Подсказка: Начальное значение переменной цикла - 2. Шаг изменения - 2 (перебираем четные числа).
Ответы (1)
Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр. заменить (v, w). нашлось (v).
Ответы (1)
Заполнить массив числами натурального ряда (1,2 ...) до тех пор пока их сумма не станет больше наперед заданного числа м вывести на печать сумму и число элементов массива
Ответы (1)