Задать вопрос
3 октября, 11:06

Выведите на экран четные числа до тех пор пока их произведение не станет больше заданного числа. в паскаль.

+3
Ответы (1)
  1. 3 октября, 11:30
    0
    Program zadacha;

    var a, p, n, i:integer;

    begin

    writeln;

    writeln ('введи число n') ; {число, до которого перемножаем четные числа}

    read (n) ;

    p:=1;

    i:=2;

    while p
    begin

    write (i) ;

    write ('; ') ;

    p:=p*i;

    i:=i+2;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Выведите на экран четные числа до тех пор пока их произведение не станет больше заданного числа. в паскаль. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)
Написать программу 4. Компьютер перебирает четные числа до тех пор, пока сума их квадратов не превысит S. Чему равна сумма квадратов? Подсказка: Начальное значение переменной цикла - 2. Шаг изменения - 2 (перебираем четные числа).
Ответы (1)
Паскаль: с Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Введите с клавиатуры два числа a и b. Если оба числа четные, то вычислите их сумки выведите результат на экран. если оба нечетные то найдите произведение этих чисел и выведите результат. Иначе, увеличить все числа в пять раз и выведите результаты.
Ответы (1)