Задать вопрос
7 мая, 13:48

Нужно на паскаль написать программу, которая будет из данного ряда чисел (5,4,3,5,5,5,4) вычислять в столбец:

1) Сколько 5 в данном ряду.

2) Сколько 4 в данном ряду.

3) Сколько 3 в данном ряду.

+5
Ответы (1)
  1. 7 мая, 13:57
    0
    Если нужно только эти числа (5,4,3,5,5,5,4), то вот программа.

    var b, c1, c2, c3:integer;

    a: array [1 ... 7] of integer;

    i: byte;

    begina[1]:=5;

    a[2]:=4;

    a[3]:=3;

    a[4]:=5;

    a[5]:=5;

    a[6]:=5;

    a[7]:=4;

    for i: = 1 to 7 do

    begin

    case a[i] of

    3: c1:=c1+1;

    4: c2:=c2+1;

    5: c3:=c3+1;

    end;

    end;

    writeln ('Количество чисел 5 в данном ряду=', c3) ;

    writeln ('Количество чисел 4 в данном ряду=', c2) ;

    writeln ('Количество чисел 3 в данном ряду=', c1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно на паскаль написать программу, которая будет из данного ряда чисел (5,4,3,5,5,5,4) вычислять в столбец: 1) Сколько 5 в данном ряду. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Напишите программу, которая по данному числу n от 1 до 9 выводит на экран n флагов. Изображение одного флага имеет размер 4*4 символов, между двумя соседними флагами также имеется пустой (из пробелов) столбец.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Составьте программу, которая формирует массив, содержащий 16 случайных вещественных чисел, принадлежащих промежутку [-2; 3] и подсчитывает сумму отрицательных чисел. Вывод в столбец с двумя десятичными знаками. Только Паскаль ABC!
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)